# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\d{7}$//gm;t' <<< "00971551234567
+971551234567
+97141234567
0551234567
041234567
"