re = /(\b\d{1,2}\D{0,3})?\b(?:Jän(?:ner)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?) \D?(\d{1,2}(st|nd|rd|th)?)?(([,.\-\/])\D?)?((19[7-9]\d|20\d{2})|\d{2})*/m
str = '20.Jänner 2022
14. Jänner 2022
14 Jänner 2022'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end