$re = '/\h*\R\s*(?=\d+=)/';
$str = '1=A
2=B
3={AA 45=45 AAAA}';
$subst = "\n<split>\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;