re = /\$\$###/
str = 'I have a string $$### ABC ###$$ $$### PQR ###$$ $$### XYZ ###$$
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end