import re
regex = re.compile(r"(fg\w+)?(\s)?(\d+|\w+)([\/\._]+\w+)([\/\._ ]?)(\d+)(\w?)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Trans 16 10.2/300 Vor-, täglich\n"
"InnoTrans 16 Reinigung 23/705 Vorr./Tägl.\n"
"InnoTrans 16 Reinigung 17/113 Vorr./Tägl.\n"
"FUNK 16 Reinigung 14.1/124 Vorr./Tägl.\n"
"InnoTrans 16 Reinigung FGSUED O/240 Vorr./Tägl.\n"
"InnoTrans 16 Reinigung 6.2/507 Vorr./Tägl.\n"
"Trans 16, 23/606, Vor + tägl. Reinigung\n"
"InnoTrans 16 Reinigung 26./141 Vorr./Tägl.\n"
"InnoTrans 16 Reinigung FGSUED O/553 Reinigung Aufbau+Gl./Tägl.+Gl.\n"
"Inno 16 Vorr. + tägl. Rein. H. 17_304\n"
"trans 4.1 412 vor u tä\n"
"InnoTrans 16 Reinigung FGSUED T10/47 Reinigung nach Stundennachweis\n"
"Inno 16 Vorr. + tägl. rein. H. 7.2C_305\n"
"Inno 16 - Storno H. 22_808\n"
"STORNO !!!!!!InnoTrans 16 Reinigung 4.2/208a Vorr./Tägl.\n"
"innotrans 16 reinig tä 21. 205")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")