$re = '/(?<=\/)[^\/,]*(?=,)/';
$str = 'stringa/stringb/123456789,abc,cde';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);