package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)"[^"]*?(\bdog\b)[^"]*?(?:(\bdog\b)[^"]*?)?"`)
var str = `Dog sighed. "I'm no super dog, nor special dog," said Dog, "I'm an ordinary dog, now leave me alone!" Dog pushed him away and made his way to the other dog.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}