#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:To:|(?!^)\G).*?<([^>]*)>(?=.*Message-ID)"
Local $sString = "Content-Type: application/ms-tnef; name="winmail.dat"" & @CRLF & _
"Content-Transfer-Encoding: binary" & @CRLF & _
"From: ABC aa DDD <aaaa.b@abc.com>" & @CRLF & _
"To: DDDDD dd <sssss.r@abc.com>" & @CRLF & _
"CC: Rrrrr rrede <sssss.rv@abc.com>, Dsssssf V R" & @CRLF & _
" <dsdsdsds.vr@abc.com>, Psssss A <pssss.a@abc.com>, Logistics" & @CRLF & _
" <LOGISTICS@abc.com>, Gssss Bsss P <gdfddd.p@abc.com>" & @CRLF & _
"Subject: RE: [MyApps] (PRO-34604) PR for Additional Monitor allocation [CITS" & @CRLF & _
" Ticket:258849]" & @CRLF & _
"Thread-Topic: [MyApps] (PRO-34604) PR for Additional Monitor allocation" & @CRLF & _
" [CITS Ticket:258849]" & @CRLF & _
"Thread-Index: AQHRXMJHE6KqCFxKBEieNqGhdNy7Pp8XHc0A" & @CRLF & _
"Date: Mon, 1 Feb 2016 17:56:17 +0530" & @CRLF & _
"Message-ID: <B7F84439E634A44AB586E3FF2EA0033A29E27E47@JETWINSRVRPS01.abc.com>" & @CRLF & _
"References: <JA.101.1453963700000@myapps.abc.com>" & @CRLF & _
" <JA.101.1453963700000.978.1454311765375@myapps.abc.com>" & @CRLF & _
"In-Reply-To: <JIRA.450101.1453963700000.978.1454311765375@myapps.abc.com>" & @CRLF & _
"Accept-Language: en-US" & @CRLF & _
"Content-Language: en-US" & @CRLF & _
"X-MS-Has-Attach:" & @CRLF & _
"X-MS-Exchange-Organization-SCL: -1" & @CRLF & _
"X-MS-TNEF-Correlator: <B7F84439E634A44AB586E3FF2EA0033A29E27E47@JETWINSRVRPS01.abc.com>" & @CRLF & _
"MIME-Version: 1.0" & @CRLF & _
"X-MS-Exchange-Organization-AuthSource: TURWINSRVRPS01.abc.com" & @CRLF & _
"X-MS-Exchange-Organization-AuthAs: Internal" & @CRLF & _
"X-MS-Exchange-Organization-AuthMechanism: 04" & @CRLF & _
"X-Originating-IP: [1.1.1.7]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")