$re = '/^[a-z]{3} \d{3}$/mi';
$str = 'ABC 123
ABC 1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);