$re = '/[^a-z| ]\bmice\b/i';
$str = 'one mice
one .mice
mice';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);