$re = '/(select.*?)(?=select|$)/';
$str = 'select * from students join (select * from teachers) join (select * from workers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);