$re = '/(\d{1,2})([a-zA-Z]{3})(\d{2})/';
$str = '21Feb14';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);