const regex = /\s{0,3}\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s{0,3}\\d{4}', 'gm')
const str = `0706-F
0335-T
4113-O
8798-L`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}