re = /^\d{2}(\d{2}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]))T(?:(?:([01]?\d|2[0-3]):)?([0-5]?\d):)?([0-5]?\d)$/m
str = '2021-04-01T11:12:51'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end