package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d+\n)(^([01][0-9]|2[0-3]):([0-5]\d):[0-5]\d,\d{3}\s-->\s([01][0-9]|2[0-3]):([0-5]\d):[0-5]\d,\d{3}\n).*`)
var str = `640
00:41:10,510 --> 00:41:12,888
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
641
00:41:15,849 --> 00:41:17,267
Por cierto, me llamo Hughie.
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
642
00:41:18,185 --> 00:41:19,186
Annie.
Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}