import re
regex = re.compile(r"\bSOURCE#.*\s*^\[1](.*\s*^(?!\[\d+]).*\bPN[QR](?:\n(?!\[\d+]).*)*(?:\n\[\d+].*)*)", flags=re.MULTILINE)
test_str = ("**** SOURCE#24 ****\n\n"
"[1] Source Location [Local/Remote] : Remote\n\n"
" Remote Host Name : PNQ\n"
" User Name : foo\n\n"
"[2] Source directory : HDPGWRF\n"
"[3] Directory poll interval : 30\n"
"[4] File name format : ACR_FILEFORMAT\n"
"[5] Delete files from source : y\n\n"
"**** SOURCE#25 ****\n\n"
"[1] Source Location [Local/Remote] : Remote\n\n"
" Remote Host Name : PNR\n"
" User Name : foo\n\n"
"[2] Source directory : HDPGWRF\n"
"[3] Directory poll interval : 30\n"
"[4] File name format : ACR_FILEFORMAT\n"
"[5] Delete files from source : y\n\n"
"**** SOURCE#26 ****\n"
"etc.....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")