package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Item[s]{0,1}.*?\:\s[A-Z][a-z]*[^Solution])`)
var str = `Item 1 for Product A: FlourSolution 1 for Product A: WaterItems 2 for Product B: MilkSolution 2 for Product B: OilItem 3 for Product C: Onions
Method`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}