$re = '/\b(\w+)\b(?:\s*[^\w\s]\s*\w+)+\s*[^\w\s]\s*\b\1\b/m';
$str = 'item1 , test, item3 ;
item4,item5;
test , item6;
alex , alex ;
some
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);