package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)exp[0-9]{1,3}`)
var str = `exp32142`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}