re = /keyword_token(.*)/m
str = '# streetname 1() refers to house number 1 with an empty () additional qualifier
keyword_token: street name 4()
keyword_token: street-name 14()
keyword_token: streetname 123()keyword_token: streetname 123()
# why is it logged one message per line, but we get the address logged twice - sometimes??
keyword_token: streetname 9(7)keyword_token: streetname 9(7)
keyword_token: streetname 27()\\r\\n a lot more text and log messages in the free form text log - one messageper line \\n
keyword_token: street-name 1-23(BLOCK D HAUS 6)keyword_token: street-name 1-23(BLOCK H HAUS 2)keyword_token: street-name 1-23(BLOCK G HAUS 3)\',
# ideal expected result:
3 fields for each record:
- street name
- house number
- additional qualifier (empty/NaN) if it is empty/missing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end