$re = '/^\d{0,8}\.\d{1,2}$|^\d{0,11}$/';
$str = '22233223.33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);