import re
regex = re.compile(r"<div class=\"equipe-top-right\">([^`]*?)<\/div>", flags=re.IGNORECASE)
test_str = ("<div class=\"equipe-top-right\">\n"
"<p><strong>Alexandre Fontanelle<br>\n"
"</strong></p>\n"
"<p><strong>Discipline</strong> : CSO</p>\n"
"<p><strong>Niveau</strong> : International</p>\n"
"<p><strong>Son lieu d’entrainement</strong> : Dans ses propres écuries à Maynal dans le Jura près de Lons le Saunier</p>\n"
"<p><strong>Sa meilleure performance</strong> : Par équipe sa meilleure performance est le titre de champion d’Europe Jeune Cavalier en 2012 ainsi que la victoire des talents Hermès au Grand Palais avec Hugo Breul en 2013.</p>\n"
"<p><strong>Performances récentes</strong> :</p>\n"
"<p>1er avec Quaprice de l’Etivant – 6 barres – CSI 3* – Megève (FRA) – Juillet</p>\n"
"<p>4e avec Urtbreaker de Lara (alias Urtbreaker du Cara) – CSI 4* – Bourg-en-Bresse (FRA) – Mai</p>\n"
"<p>1er avec Tzara Belin – CSI 2* – Mijas (ESP) – Mai</p>\n"
"<p>1er avec Quaprice de l’Etivant – GP – Bonneval (FRA) – Avril</p>\n"
"<p><strong>Ce que les vêtements Horse Pilot lui apportent</strong> : Très agréable à porter grâce à leur légèreté et leurs élasticité, il aime beaucoup la technologie apportée à la collection qui lui offre le plus grand confort</p>\n"
"<p><strong>Son conseil pour être plus efficace</strong> : Du travail et de la rigueur sont pour lui les clés de la réussite</p>\n"
"</div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")