re = /[^\w'-]+(?=diagnosis)/m
str = 'Some other medical terms and stuff diagnosis of R45.2 was entered for this patient. Where did Doctor Who go? Then xxx feea fdsfd
'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result