#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "`[^``]*`(*SKIP)(*F)|\(link: ([^)]+\))"
Local $sString = "Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet." & @CRLF & _
"(link: http://wikipedia.org text: Wikipedia title: lala cat: goto)" & @CRLF & _
"(link: http://wikipedia.org text: Wikip:edia title: lala cat: goto)Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. (videotest: text: test) Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur `(link: http://bar.foo cat: goto title: foo.title text: Wikip:edia )`sadipscing elitr, magna `aliquyam` erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.(link: http://bar.foo cat: goto title: foo.title text: Wikip:edia )Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam" & @CRLF & _
"```" & @CRLF & _
"(link: http://bar.foo cat: goto title: foo.title text: Wikip:edia )" & @CRLF & _
"```" & @CRLF & _
"accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.(link: http://moep.lala text: foobar title: foo.bar cat: foobarcat)Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")