$re = '/(?!^)https:.*\//';
$str = 'https://www.google.com/url?rct=3Dj\\u0026sa=3Dt\\u0026url=3Dhttps://rivesjournal.com/inside-track-trading-focus-on-shares-of-adobe-systems-inc-adbe/48453/\\u0026ct=3Dga\\u0026cd=3DCAEYASoTOT';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);