package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)(?:\s*-\s*)(.*)`)
var str = `My heart will go on - Celine Dion
My heart will go on - Celine Dion
My heart will go on - Celine Dion
My heart will go on -Celine Dion
My heart will go on- Celine Dion
My heart will go on-Celine Dion`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}