re = /\b[^,;\s]+\s+[^;,\s]+\s*\([^;]+?\):/
str = 'string concatenate (string& a, string& b):
return a+b;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end