$re = '/(\d+) (\w+)/m';
$str = '3 blue, 4 red; 1 red, 2 green, 6 blue; 2 green';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);