re = /^.+,.+\n.+\n.+\n\s/m
str = '...
830 ORLANDO, 382.000CS $
FL 16.2400
840 TAMPA, FL 382.000CS $
16.2400
Subtotal 41,310.000CS
Contract Total 115,560.000CS $ 1,569,663.00
Contractor Total 115,560.000 C S $ 1,569,663.00
ABC, INC.
PO Box 11
NEW YORK, NY 11111-1111
SOME RANDOM COMMODITY
90 New York, NY 39,900.000LB $
0.4925
110 CLEVELAND, OH 39,900.000LB $
0.4925
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end