re = /^(https?:\/\/)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-]*)*\/?$/
str = 'http://www.bbc.co.uk/food/recipes/bourbon-glazed_monster_11608'
# Print the match result
str.match(re) do |match|
puts match.to_s
end