$re = '/(?:[^,\\\\]|\\\\.)+/';
$str = 'string1, string2, string\\,3, string4, foo\\\\bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);