using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?<n>foo)|(?<n>bar))\k<n>){2}";
string input = @"foofoofoofoo
barbarbarbar
barbarfoofoo
foofoobarbar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}