import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\/|v=|vi=|v%)(?<id>([\\-\\w]){10,14}))";
final String string = "youtu.be/DFYRQ_zQ-gk\n"
+ "DFYRQ_zQ-gk\n"
+ "https://youtu.be/KjpQF3nYGoc?list=PLakykuPxo3cgydAififYWycQdFKpXZLYr&t=1\n\n"
+ "http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://m.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://www.youtube.com/watch/-wtIMTCHWuI\n"
+ "http://youtube.com/watch/-wtIMTCHWuI\n"
+ "http://m.youtube.com/watch/-wtIMTCHWuI\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "http://youtube.com/v/dQw4w9WgXcQ\n"
+ "http://m.youtube.com/v/dQw4w9WgXcQ\n\n"
+ "http://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "http://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "http://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://m.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n\n"
+ "http://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n\n"
+ "http://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "http://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "http://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
+ "http://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "http://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "http://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "http://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "http://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
+ "http://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "http://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "http://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "http://www.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "http://youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "http://m.youtube.com/watch/-wtIMTCHWuI?app=desktop\n\n\n"
+ "http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n\n"
+ "http://youtu.be/-wtIMTCHWuI\n"
+ "https://youtu.be/-wtIMTCHWuI\n"
+ "https://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n"
+ "https://youtu.be/oTJRivZTMLs&feature=channel\n"
+ "http://youtu.be/lalOy8Mbfdc?t=1\n"
+ "http://youtu.be/lalOy8Mbfdc?t=1s\n"
+ "http://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-\n\n"
+ "http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n\n"
+ "http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "http://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "http://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n\n"
+ "http://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "http://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "http://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n\n"
+ "http://www.youtube.com/embed/lalOy8Mbfdc\n"
+ "http://youtube.com/embed/lalOy8Mbfdc\n"
+ "http://m.youtube.com/embed/lalOy8Mbfdc\n"
+ "http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://m.youtube.com/embed/nas1rJpm7wY?rel=0\n\n"
+ "http://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n"
+ "https://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n\n\n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "http://youtube.com/e/dQw4w9WgXcQ\n"
+ "http://m.youtube.com/e/dQw4w9WgXcQ\n\n\n"
+ "http://www.youtube.com/shorts/j9rZxAF3C0I\n"
+ "http://youtube.com/shorts/j9rZxAF3C0I\n"
+ "http://m.youtube.com/shorts/j9rZxAF3C0I\n\n"
+ "http://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "http://youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "http://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n\n\n"
+ "http://www.youtube.com/live/8hBmepWUJoc\n"
+ "http://youtube.com/live/8hBmepWUJoc\n"
+ "http://m.youtube.com/live/8hBmepWUJoc\n\n"
+ "http://www.youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "http://youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "http://m.youtube.com/live/8hBmepWUJoc?app=desktop\n\n\n"
+ "https://youtube.com/user/GitHub#p/a/u/1/lalOy8Mbfdc\n"
+ "https://www.youtube.com/user/GitHub#p/u/1/lalOy8Mbfdc\n"
+ "https://www.youtube.com/user/GitHub#p/u/1/lalOy8Mbfdc?rel=0\n"
+ "https://www.youtube.com/user/GitHub#p/a/u/2/lalOy8Mbfdc\n"
+ "https://www.youtube.com/user/GitHub#p/u/11/lalOy8Mbfdc\n"
+ "https://www.youtube.com/user/GitHub#p/u/1/lalOy8Mbfdc\n"
+ "https://www.youtube.com/GitHub?v=lalOy8Mbfdc\n\n\n"
+ "http://www.youtube.com/?v=dQw4w9WgXcQ\n"
+ "http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/?v=lalOy8Mbfdc&feature=channel\n"
+ "http://youtube.com/?vi=dQw4w9WgXcQ\n"
+ "http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/?vi=lalOy8Mbfdc&feature=channel\n"
+ "http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "http://youtube.com/?feature=channel&v=lalOy8Mbfdc\n\n\n"
+ "http://youtube.com/watch?vi=dQw4w9WgXcQ\n"
+ "http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?vi=lalOy8Mbfdc&feature=channel\n\n"
+ "http://youtube.com/vi/dQw4w9WgXcQ\n"
+ "http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/vi/lalOy8Mbfdc&feature=channel\n\n"
+ "dead domain:\n"
+ "http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}