$re = '/^([a-z])(?!\1)([a-z])(?:\1\2)*\1?$/m';
$str = 'ababababa
mnmnmnmnmnmn
aaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);