#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]"
Local $sString = "WEBVTT" & @CRLF & _
"" & @CRLF & _
"NOTE duration:"02:09:15.8840000"" & @CRLF & _
"" & @CRLF & _
"NOTE language:en-us" & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.881069481372833" & @CRLF & _
"" & @CRLF & _
"d8d8fcb9-ccb1-41f2-a75e-0c3088e95dc2" & @CRLF & _
"00:00:01.720 --> 00:00:07.798" & @CRLF & _
"So we're going" & @CRLF & _
"to try to" & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.881069481372833" & @CRLF & _
"" & @CRLF & _
"a8f8cc83-48c4-4acc-881b-85b37c73b42c" & @CRLF & _
"00:00:07.798 --> 00:00:13.876" & @CRLF & _
"to use Microsoft" & @CRLF & _
"Teams next week," & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.881069481372833" & @CRLF & _
"" & @CRLF & _
"d2738b5d-b7ee-4b58-8388-4b7524c3c563" & @CRLF & _
"00:00:13.876 --> 00:00:19.954" & @CRLF & _
"so will post" & @CRLF & _
"it as a" & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.802268326282501" & @CRLF & _
"" & @CRLF & _
"baab9c8e-f018-48a2-a355-b23eb29174e9" & @CRLF & _
"00:00:19.954 --> 00:00:25.728" & @CRLF & _
"teams meeting. If you've never" & @CRLF & _
"used prosoft teams before, it's" & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.932209372520447" & @CRLF & _
"" & @CRLF & _
"73231caa-7ae7-4046-acdf-c6691c7c3c41" & @CRLF & _
"00:00:25.728 --> 00:00:30.013" & @CRLF & _
"it's. Basically the same thing," & @CRLF & _
"just a little more stable." & @CRLF & _
"" & @CRLF & _
"NOTE Confidence: 0.825244784355164" & @CRLF & _
"" & @CRLF & _
"3ab6c4cb-9d70-4140-8356-c0f7c2316874" & @CRLF & _
"00:00:30.730 --> 00:00:35.224" & @CRLF & _
"Then they will put the link in" & @CRLF & _
"Quercus and send it out as an"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")