re = /\s+(\w+)[ ]?:[ ]?['"]?(.[^'^"\n]+)['"]?/m
str = '
Name: \'Sample\',
Age: 23
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end