const regex = /.\w+\W+(?<EventTime>[^"]+)\W+\w+\W+(?<HostName>\w+).+?EventID\W+(?<EventID>\w+).+?Message\W+(?<Message>[^"]+).+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\w+\\W+(?<EventTime>[^"]+)\\W+\\w+\\W+(?<HostName>\\w+).+?EventID\\W+(?<EventID>\\w+).+?Message\\W+(?<Message>[^"]+).+', '')
const str = `"EventTime":"2017-08-11 10:40:07","Hostname":"School4","Keywords":-9187343239835811840,"EventType":"INFO","SeverityValue":2,"Severity":"INFO","EventID":7036,"SourceName":"Service Control Manager","ProviderGuid":"{555908D1-A6D7-4695-8E1E-26931D2012F4}","Version":0,"Task":0,"OpcodeValue":0,"RecordNumber":263066,"ProcessID":548,"ThreadID":7528,"Channel":"System","Message":"Application Experience 서비스가 중지 상태로 들어갔습니다.","param1":"Application Experience","param2":"중지","EventReceivedTime":1502415607,"SourceModuleName":"in","SourceModuleType":"im_msvistalog"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}