$re = '/\d+(?=$)/';
$str = 'T110A17014 T110A17014
T110A17014
T110A17099';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);