import re
regex = re.compile(r"(\d\ *?\-*?){9}([A-Za-z]){1}", flags=re.MULTILINE)
test_str = ("11 22 33 44 5T\n\n"
"11-- ---2233445T")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")