$re = '/(\d( |-){0,1}){9}([A-Za-z])/m';
$str = '11 22 33 44 5T
11-- ---2233445T';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);