$re = '/(?:(?:(\/)(\*)|(["\'])).*?(?:\2\1|\3))|(?:\/\/[^\n]+)/ms';
$str = '
//get means only read, but not to mutate data
Get(BooksWithAuthors)
//default queries via mycel
.Query()
//junction table to pair books and authors
.From("BookAuthor".As(BA))
//main table for books
.Join(left: Books.As(B) => B.Id == BA.BookId)
//main table for authors
.Join(left: Authors.As(A) => A.Id == BA.AuthorId)
//groups by column, body allows to restore data (restructuring)
.GroupBy(B.Id, => { B.Authors.Add(A) })
//ignore still registerd data objects for the response
.SelectIgnore(BA)
//or select only that fields or objects you want to response
.Select(B)
.Foo("//wrong-comment-inside-quotes")
.Foo(\'//wrong-comment-inside-single-quotes\')
.Foo(\'some /*wrong-comment*/ inside\')
;
//get means only read, but not to mutate data
Get(BooksWithAuthorsByMethod)
//using individual backside methods (created by own)
.GetBooksWithAuthors(id:6, filter:{key:\'minAuthorAge\', value:17})
;
/*
comments
"over"
*/
/*
\'multiply
lines\' //with wrong comments inside
*\\
aa"aasdfasdasdf
asdfasdfasdf
asdfasdf"asdfasd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);