re = /\(([^()]*)\)(?=(?:[^()]*\)){2})/m
str = '(aaa) (ee (ff (gg))) (bbb (ccc)) ddd'
subst = '{$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result