re = /^(?:(.)(?!.*\1$))+/m
str = 'a
aa
abc
abca
repeated last char
unique last char'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end