$re = '~(?m)/\*\*$\n?|^\h+\*\h.*$\n?|^\h+\*/$\n?|(?<=\*/\n)(?:\h+@.*\n)*\K.+\n?~m';
$str = '// case 1
/**
* check if the user level is super admin
* @returns {boolean} true if the user has the right to access super admin endpoints
*/
@UseGuards(AuthGuard(\'jwt\'), LevelsGuard)
@Levels(LevelEnum.superadmin)
@Get(\'check/superadmin\')
@ApiBearerAuth()
checkSuperAdminLevel(): boolean {
return true;
}
// case 2
/**
* check if the user level is super admin
* @returns {boolean} true if the user has the right to access super admin endpoints
*/
@Get(\'check/superadmin\')
@ApiBearerAuth()
checkSuperAdminLevel(): boolean {
return true;
}
// case 3
/**
* check if the user level is super admin
* @returns {boolean} true if the user has the right to access super admin endpoints
*/
checkSuperAdminLevel(): boolean {
return true;
}
// case 4
/** lorem ipsum */
// case 5
lorem ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);