# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\d|:)+)\s(.+)"
test_str = ("0:08 Waltz No. 2 (Dmitri Shostakovitch)\n"
"4:01 Dance of the Knights (Sergei Prokofiev)\n"
"9:42 Sabre Dance (Aram Khachaturian)\n"
"12:09 1812 Overture Finale (Pyotr Ilyich Tchaikovsky) (My Absolute Favorite One)\n"
"15:57 Flight of the Bumblebee \"From The Tale of Tsar Sultan\" (Nikolai Rimsky-Korsakov)\n"
"19:31 Rite of Spring Sacrifical Dance (Igor Stravinsky)\n"
"24:09 Piano Concerto No. 2 (Moderato) (Sergei Rachmaninoff)\n"
"34:22 Polovtsian Dances \"From Prince Igor\" (Alexander Borodin)\n"
"39:20 Etude Op. 8 No. 12 (Alexander Scriabin)\n"
"41:51 Sailors' Dance (Reinhold Gliere)\n"
"45:13 Dance of the Sugar Plum Fairy (Pyotr Ilylich Tchaikovsky)\n"
"47:46 Piano Concerto No. 1 (Allegro) (Pyotr Ilylich Tchaikovsky)\n"
"51:54 Ruslan and Lyudmila Overture (Mikhail Glinka)\n"
"54:51 Swan Lake Waltz (Pyotr Ilyich Tchaikovsky)\n"
"1:01:47 Dance of the Pagan Monster (Sergei Prokofiev)\n"
"1:05:01 Overture from the Children of Captain Grant (Isaak Dunaevsky)\n"
"1:08:52 Symphony No. 5 (Allegro Non Troppo) (Dmitri Shostakovitch) (My Favorite One)\n"
"1:12:00 Swan Theme (Pyotr Ilyich Tchaikovsky)\n"
"1:14:53 Night on Bald Mountain (Modest Mussorgsky)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.