# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"commit[\s\S]+?(?=commit [a-z0-9]+|$)"
test_str = ("commit 7200304f2e965e348dfa362a4adf80e4e0a3d621 (HEAD -> master, tag: v0.5.0.1, origin/master, origin/HEAD)\n"
"Author: Jonathan Dance <jd@wuputah.com>\n"
"Date: Mon May 21 11:02:39 2018 -0700\n\n"
" 0.5.0.1\n\n"
"commit 7314c4a5f5c7502babe45fdd98e65c7210fbf92b\n"
"Author: Jonathan Dance <jd@wuputah.com>\n"
"Date: Mon May 21 11:01:31 2018 -0700\n\n"
" add task to build with chmod -R beforehand\n"
" \n"
" fixes #129\n\n\n"
"commit 7314c4a5f5c7502babe45fdd98e65c7210fbf92b\n"
"Author: Jonathan Dance <jd@wuputah.com>\n"
"Date: Mon May 21 11:01:31 2018 -0700\n\n"
" add task to build with chmod -R beforehand\n"
" \n"
" fixes #129")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.