re = /\.\s*([^:]*)\s*:\s*([^.]*)/m
str = '. Reversion: A reversion is turning back again to a previous state or condition. Rhetoric: Rhetoric is the skill or art of using language to persuade or influence people, especially language that sounds impressive but may not be sincere or honest.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end