import re
regex = re.compile(r"^([A-Za-z]{2,})\/([A-Za-z]{2,})\/([A-Z]{2}-\d{4,})[\/\-\_\ ]([\w\-\ ]*)$", flags=re.MULTILINE)
test_str = ("ft/rb/FE-5623/Do_stuff_that_15_awe-some\n"
"ft/rb/FE-5623/Do stuff that 15 awe-some\n"
"ft/rb/FE-5623_Do stuff that 15 awe-some\n"
"ft/rb/FE-5623-Do stuff that 15 awe-some\n"
"ft/rb/FE-5623 Do stuff that 15 awe-some\n"
"not at all\n"
"f_t/rb/FE-5623-Do stuff that 15 awe-some\n"
"ft/r_b/FE-5623-Do stuff that 15 awe-some\n"
"ft/rb/FE_5623-Do stuff that 15 awe-some\n"
"FE-5623/not_quite\n"
"ft/rb/FE-5623/Do_stuff_that_!! not really\n"
"_azeaze\n"
"azea_zae")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")