package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[y](?:\[[^\][]*])*(\w+)`)
var str = `[X]word[y][Z]another`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}