#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?:[\da-f]{0,4}:){1,7}(?:(?<ipv4>(?:(?:25[0-5]|2[0-4]\d|1?\d\d?)\.){3}(?:25[0-5]|2[0-4]\d|1?\d\d?))|[\da-f]{0,4})"
Local $sString = "2001:db8:3333:4444:5555:6666:7777:8888" & @CRLF & _
"2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF" & @CRLF & _
"2001:0db8:0001:0000:0000:0ab9:C0A8:" & @CRLF & _
"fffe:3465:efab:23fe:2235:6565" & @CRLF & _
"2001:0000:6dcd:8c74:::ac32:6a1" & @CRLF & _
"2345:0425:2CA1:::5673:23b5" & @CRLF & _
"2001:db8:1::ab9:C0A8:102" & @CRLF & _
"2001:db8::1234:5678" & @CRLF & _
"FF02:0:0:0:0:0:0:2" & @CRLF & _
"fdf8:f53b:82e4::53" & @CRLF & _
"fe80::200:5aee:feaa:20a2" & @CRLF & _
"2001:0000:4136:e378:" & @CRLF & _
"8000:63bf:3fff:fdd2" & @CRLF & _
"2001:db8::" & @CRLF & _
"::1234:5678" & @CRLF & _
"2000::" & @CRLF & _
"2001:db8:a0b:12f0::1" & @CRLF & _
"2001:4:112:cd:65a:753:0:a1" & @CRLF & _
"2001:0002:6c::430" & @CRLF & _
"2001:5::" & @CRLF & _
"fe08::7:8" & @CRLF & _
"2001:10:240:ab::a" & @CRLF & _
"2002:cb0a:3cdd:1::1" & @CRLF & _
"2001:db8:8:4::2" & @CRLF & _
"ff01:0:0:0:0:0:0:2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1:2:3:4:5:6:7:8" & @CRLF & _
"1::3:4:5:6:7:8" & @CRLF & _
"1::4:5:6:7:8" & @CRLF & _
"1:2:3::5:6:7:8" & @CRLF & _
"1::7:8" & @CRLF & _
"1:2:3:4:5::7:8" & @CRLF & _
"1:2:3:4:5::8" & @CRLF & _
"::2:3:4:5:6:7:8" & @CRLF & _
"::8" & @CRLF & _
"::" & @CRLF & _
"::1" & @CRLF & _
"" & @CRLF & _
"::ffff:192.0.2.47" & @CRLF & _
"::255.255.255.255" & @CRLF & _
"::ffff:255.255.255.255 " & @CRLF & _
"::ffff:0:255.255.255.255" & @CRLF & _
"2001:db8:3:4::192.0.2.33" & @CRLF & _
"64:ff9b::192.0.2.33" & @CRLF & _
"2001:db8:3333:4444:5555:6666:1.2.3.4" & @CRLF & _
"24a6:57:c:36cf:0000:5efe:109.205.140.116" & @CRLF & _
"::11.22.33.44" & @CRLF & _
"::10.0.0.3" & @CRLF & _
"2001:db8::123.123.123.123" & @CRLF & _
"::ffff:10.0.0.3" & @CRLF & _
"::1234:5678:91.123.4.56" & @CRLF & _
"::1234:5678:1.2.3.4" & @CRLF & _
"2001:db8::1234:5678:5.6.7.8" & @CRLF & _
"2001:db8:3:4:5::192.0.2.33"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")